Stella Connect Service Degradation Notification
Incident Report for Stella Connect
Resolved
This issue has been resolved.
Posted Jul 29, 2019 - 14:23 EDT
Monitoring
We have identified an issue where users were unable to access the Connect app. Our team has resolved the issue and we are continuing to monitor the situation.
Posted Jul 29, 2019 - 14:19 EDT
Investigating
We are currently experiencing a service degradation on Stella Connect. We are aware of the incident and will provide an update within the hour.
Posted Jul 29, 2019 - 13:54 EDT
This incident affected: Stream (Displaying Survey Response Data), Surveys (Survey Experience), API & Integration (Requests API, Email Primary), and Feedback Dashboards (Company Trends).