Stella Connect Service Degradation Notification
Incident Report for Stella Connect
Resolved
This incident has been resolved by the primary email service provider.
Posted May 02, 2019 - 22:15 EDT
Monitoring
Our application has returned to normal. We are continuing to monitor the situation with our primary email service provider.
Posted May 02, 2019 - 18:15 EDT
Identified
We are currently experiencing a service degradation with our primary email service provider. We are aware of the incident and will provide an update within the hour.
Posted May 02, 2019 - 17:11 EDT
This incident affected: API & Integration (Email Primary).