Stella Connect Service Degradation Notification
Incident Report for Stella Connect
Resolved
The incident has been resolved. More details will be provided about cause and impact when we have more details.
Posted May 14, 2019 - 17:40 EDT
Monitoring
We experienced an issue with Connect requests. A fix has been implemented and Stella Connect is now fully operational. We are still investigating root cause and impact, and will provide another update within the hour.
Posted May 14, 2019 - 16:21 EDT
Investigating
We are currently experiencing a service degradation on Stella Connect. We are aware of the incident and will provide an update within the hour.
Posted May 14, 2019 - 15:11 EDT
This incident affected: Response Collection (Feedback app) and Request Sending (Request API).