Agent Connect Service Degradation Notification

Incident Report for Stella Connect

Resolved

Our Engineering team have verified that the issue has been resolved.
Posted Nov 05, 2025 - 22:32 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 05, 2025 - 18:31 EST

Investigating

The application is currently experiencing elevated error rates. Our team is investigating and will provide updates as available.
Posted Nov 05, 2025 - 13:58 EST