Stella Connect Service Degradation Notification
Incident Report for Stella Connect
Resolved
This incident has been resolved. It was caused by an outage within Amazon Web Services, an underlying piece of our architecture.

The only affected systems was for sending surveys via Batch file requests. Any client that attempted to load a new file would have received an error and we are unable to receive that file. You can now re-upload that file and it will get processed as normal.
Posted Aug 31, 2019 - 13:22 EDT
Identified
We have identified an issue with our batch request process, and are working on a fix.
Posted Aug 31, 2019 - 09:18 EDT
Investigating
We are currently experiencing a service degradation on Stella Connect. We are aware of the incident and will provide an update within the hour.
Posted Aug 31, 2019 - 09:01 EDT