Stella Connect Service Degradation Notification
Incident Report for Stella Connect
Resolved
We experienced a brief unplanned period of downtime (roughly 8 minutes long), during which time the Stella Connect app was unreachable. The issue has been resolved. No survey data was lost during this period.
Posted Sep 30, 2019 - 15:41 EDT
Investigating
We are currently experiencing a service degradation on Stella Connect. We are aware of the incident and will provide an update within the hour.
Posted Sep 30, 2019 - 15:29 EDT
This incident affected: Stream (Displaying Survey Response Data) and Feedback Dashboards (Company Trends).