Stella Connect Service Degradation Notification
Incident Report for Stella Connect
Resolved
Routine maintenance caused requests to the web app and data return API to fail from approximately 12:27-12:30PM EDT. Integrated survey requests and survey responses were not impacted.
Posted Sep 19, 2019 - 12:48 EDT
Investigating
We are currently experiencing a service degradation on Stella Connect. We are aware of the incident and will provide an update within the hour.
Posted Sep 19, 2019 - 12:29 EDT
This incident affected: Stream (Displaying Survey Response Data), Feedback Dashboards (Company Trends), and API & Integration (Data Return API).