Stella Connect Service Degradation Notification
Incident Report for Stella Connect
Resolved
This incident has been resolved.
Posted Sep 30, 2019 - 21:34 EDT
Monitoring
The alerting has been deemed to be a false alarm. We are continuing to monitor the situation.
Posted Sep 30, 2019 - 20:48 EDT
Investigating
We are currently experiencing a service degradation on Stella Connect. We are aware of the incident and will provide an update within the hour.
Posted Sep 30, 2019 - 19:53 EDT