Additional question response data not displaying on Company Trends
Incident Report for Stella Connect
Resolved
This incident has been resolved.
Posted Jul 26, 2019 - 15:02 EDT
Investigating
We are aware of an issue where additional question data is not displaying on Company Trends. We are currently investigating this issue, and will provide an update within the hour.
Posted Jul 26, 2019 - 13:46 EDT
This incident affected: Feedback Dashboards (Company Trends).