Support Chat is Unavailable

Incident Report for Stella Connect

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 16:40 EST

Monitoring

A fix has been implemented and we are monitoring for the results for full recovery.

Customers who tried to initiate a Support chat or have sent messages within the last hour, may need to try again.
Posted Jan 09, 2026 - 15:54 EST

Identified

We are aware of an issue impacting our third-party Support chat feature, which is currently unavailable. Our vendor is actively investigating and working to resolve these issues as soon as possible.
Posted Jan 09, 2026 - 15:32 EST