Stella Connect Service Degradation Notification
Incident Report for Stella Connect
Resolved
From approximately 3:40-3:50 EST, the survey requests API experienced elevated error rates.
Posted Feb 07, 2022 - 19:08 EST
Investigating
We are currently experiencing a service degradation on Stella Connect. We are aware of the incident and will provide an update within the hour.
Posted Feb 07, 2022 - 15:53 EST