Data Discrepancy Issue
Incident Report for Stella Connect
Resolved
This incident has been resolved.
Posted Sep 03, 2021 - 14:47 EDT
Monitoring
A fix has been implemented for the data discrepancy involving Response Rate metrics where calculations included archived and suppressed surveys. We are still monitoring for any additional discrepancies.
Posted Jul 08, 2021 - 17:05 EDT
Identified
Our team has identified an issue causing calculation of Response Rate metrics to include discrepancies - calculations are currently including archived and suppressed surveys. We are working diligently on a fix and will provide updates here as soon as possible!
Posted Jul 06, 2021 - 16:35 EDT
This incident affected: Stream (Displaying Survey Response Data) and Feedback Dashboards (Company Program).