Agent Connect Service Degradation Notification

Incident Report for Stella Connect

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 11:44 EDT

Monitoring

A fix has been implemented to address the issues impacting the web application.

Our Production Services & Engineering teams are continuing to monitor to ensure full recovery.
Posted Oct 08, 2025 - 18:59 EDT

Identified

We've identified an issue affecting the web application that may result in certain pages loading with delays. Our team has identified the cause and is currently working on a resolution.

We'll continue to provide updates as they are available.
Posted Oct 08, 2025 - 18:03 EDT

Investigating

The application is currently experiencing elevated error rates. Our team is investigating and will provide updates as available.
Posted Oct 08, 2025 - 15:23 EDT
This incident affected: Web application.