Agent Connect Service Degradation Notification

Incident Report for Stella Connect

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 17:27 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2025 - 13:31 EDT

Identified

We have identified an issue with one of our web application components. This is causing users of the web application to experience elevated error rates. Survey requests and responses are not impacted at this time. We are continuing to investigate the cause of this issue and will continue to provide updates as they are available.
Posted Jul 29, 2025 - 13:20 EDT

Investigating

The application is currently experiencing elevated error rates. Our team is investigating and will provide updates as available.
Posted Jul 29, 2025 - 12:11 EDT
This incident affected: Web application.